PODSTAWY ARKUSZY KALKULACYJNYCH

 


Wprowadzanie formuł

Aby arkusz wykonywał obliczenia, należy wprowadzić formułę do komórki, w której ma się wyświetlać wynik.
Formuła to wzór, według którego następuje obliczenie wartości.
Formuła zawiera m.in. adresy komórek, z których należy pobrać dane oraz znaki działania matematycznego (operatory).

Wprowadzanie formuły, która dodaje do siebie zawartość dwóch komórek

 

Wprowadzanie formuły rozpoczyna się od wpisania na klawiaturze znaku = (równa się). Następnie należy kliknąć na komórce, która bierze udział w formule jej adres zostanie wpisany do komórki, wprowadzić znak działania matematycznego (np. + plus) i kliknąć na drugiej komórce.
Gotową formułę należy zatwierdzić klawiszem Enter.

Podstawowe operatory działań:

+ dodawanie np. =A1+B1,
- odejmowanie np.=A1-365,
* (gwiazdka) mnożenie np. =A5*B12,
/ dzielenie np. =B15/C20,
^ (daszek) potęgowanie np. =A5^3,
& (ampersand ) łączenie (konkatenacja) tekstów.


Formuła może zawierać:

  • adresy np. =C10 $B$8 (adres może mieć różną postać patrz rozdział o adresowaniu),
  • liczby np. =C20/365,
  • teksty np. = "Pani/Pan " &B5& " " &C5 (np. gdy B5 i C5 jest wpisane imię i nazwisko),
  • funkcje np. =SUMA(C10:C20).


Działania w formule wykonywane są zgodnie z matematyczną kolejnością (np. najpierw mnożenie, potem dodawanie). Przy działaniach o tym samym priorytecie (np. mnożenie i dzielenie) działania wykonywane są od lewej do prawej strony formuły.
Do wymuszania kolejności wykonywania działań stosuje się nawiasy okrągłe np. =((A1+A3)/B7-(B7-365)/12)*10%.

Po wprowadzeniu formuły w komórce wyświetlany jest wynik działania, a formuła jest widoczna nad obszarem roboczym na pasku formuły.
Na pasku formuły można również:

  • wprowadzać i modyfikować formułę,
  • zatwierdzać formułę poprzez kliknięcie na przycisku Zapisz (wygląda jak haczyk).

Formuły można kopiować i przenosić do innych komórek.
Podczas przenoszenia adresy występujące w formule nie ulegają zmianie.
Podczas kopiowania oraz podczas przeciągania za pomocą uchwytu wypełnienia adresy zmieniają się w zależności od sposobu adresowania (patrz podrozdział o adresowaniu).
Wygodną formą kopiowania jest przeciąganie zawartości za pomocą uchwytu wypełnienia (patrz podrozdział Serie danych).




 

Przykładowe formuły:
=B4/365, =A1+B7/G34 =((D1+D3)/E3))^(1/2)

quiz_html_arkusze_2_jaka_formula_powinna_byc_umieszczona_E8


Wprowadzanie formuł